Joviano

Bem vindo ao

Blog do Jovi!

O blog do Jovi tem como objetivo ajudar você com suas dúvidas, além de expandir seu conhecimento através da informação.

PROCV , PROCX , SOMASES com caractere curinga

Bora mergulhar fundo em duas das funções mais poderosas do Excel: PROCV e PROCX. Essas funções são essenciais para quem quer fazer buscas precisas e flexíveis em suas planilhas.

Vamos aprender a usá-las para buscas exatas e também como usar caracteres curingas para encontrar exatamente o que você precisa.

O tradicional PROCV exato

O básico do PROCV

O PROCV (Procura Vertical) é uma das funções mais antigas e populares do Excel. Ele é usado para procurar um valor na primeira coluna de uma tabela e retornar um valor na mesma linha de uma coluna especificada.

Vamos começar com um exemplo básico. Imagine que você tem uma lista de produtos com seus respectivos preços e deseja encontrar o preço de um produto específico.

= PROCV("Produto A"; A2:B10; 2; 0)

Nesta fórmula:

  • "Produto A" é o valor que você está procurando.
  • A2:B10 é o intervalo de células onde a busca será realizada.
  • 2 indica que queremos o valor da segunda coluna do intervalo.
  • 0 significa que queremos uma correspondência exata.

Se “Produto A” estiver na primeira coluna do intervalo A2:A10, a fórmula retornará o preço correspondente na coluna B.

PROCV aproximado

Mas e se você quiser encontrar algo que não está exatamente igual? Entra em cena o PROCV aproximado.
Só que, vamos combinar, ele é meio traiçoeiro, então use com cuidado, ok?

=PROCV(85; A2:B10; 2)

Aqui, a falta do quarto argumento da função, fará o Excel procurar o valor mais próximo de 85 na primeira coluna do intervalo A2:B10.

Lembrando que ele sempre trará o mais próximo anterior, então cuidado para não usar isso quando precisar de precisão.

tabela no excel

Se você mudar a ordem, ele mudará o resultado, pois o “menor “valor anterior” é outro:

tabela no excel

A evolução do PROCX

Agora, se o PROCV é o amigo leal, o PROCX é o amigo que foi para o intercâmbio, voltou mais inteligente, mais forte, e ainda te trouxe um presente.

O básico do PROCX

O PROCX veio para resolver as limitações do PROCV. Ele permite buscar valores em qualquer parte de uma tabela e retornar resultados de forma dinâmica.

Vamos ver um exemplo básico de PROCX:

=PROCX("Produto B"; A2:A100; B2:B100)

Neste exemplo:

  • "Produto B" é o valor que você está procurando.
  • A2:A100 é a coluna onde a busca será realizada.
  • B2:B100 é a coluna de onde o valor correspondente será retornado.

O uso de caracteres curingas no PROCV e PROCX

O que são caracteres curingas?

Os caracteres curingas são usados para substituir um ou mais caracteres em uma busca. No Excel, os dois curingas mais comuns são:

  • * (asterisco): representa qualquer sequência de caracteres.
  • ? (ponto de interrogação): representa um único caractere.

Busca com curingas usando PROCV

Embora o PROCV não suporte curingas diretamente, podemos usar uma combinação de funções para obter o mesmo efeito. Vamos ver um exemplo:

= PROCV("Produto A*"; A2:B10; 2; 0)

Essa fórmula funciona idêntico à primeira explicada nesse artigo, mas, ao invés de buscar a correspondência exata, ela vai procurar a primeira correspondência que começa com “PRODUTO A”

Da mesma forma que temos o “começa” com, podemos testar outras possibilidades:

  • *Seutexto : representa o termina com
  • *SeuTexto* : representa o contém
  • SeuTexto* : representa o começa com

Usando o ponto de interrogação (?)

Vamos procurar por um produto que tenha exatamente seis caracteres, começando com “C” e terminando com “a”.

= PROCX("C????a"; A2:A100; B2:B100)

Aqui, C????a corresponde a qualquer célula na coluna A2:A100 que tenha exatamente seis caracteres, começando com “C” e terminando com “a”. O valor correspondente na coluna B2:B100 será retornado.

Convite para ver o vídeo completo

Quer ver tudo isso na prática? Confira o vídeo completo onde eu mostro passo a passo como usar o PROCV e o PROCX com exemplos reais. Você vai ver como é fácil e prático usar essas funções no seu dia a dia.

PROCV [ PROCX, SOMASES ] usando COMEÇA, TERMINA, CONTÉM

Transição de Excel para mestre em tratamento de dados

Está na hora de levar suas habilidades de Excel para o próximo nível. Venha aprender como transformar horas de trabalho tediosas em minutos com Power Query, SQL, DAX e Python na nossa Formação Power Query 2.0.

Não perca essa oportunidade de se tornar um mestre em tratamento de dados!

Conclusão

Ficou claro que o PROCV e o PROCX são ferramentas poderosas para buscas no Excel. Usá-las corretamente pode fazer toda a diferença no seu trabalho. Mas, se você ainda está na dúvida sobre se deve se aprofundar mais nesses conhecimentos, pensa bem: continuar gastando horas em tarefas repetitivas ou se tornar um ninja do tratamento de dados? A escolha é sua, FERA. Não deixe essa oportunidade passar. Matricule-se na Formação Power Query 2.0 e transforme sua carreira!

Deixe um comentário

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Receba conteúdos do Jovi!

Digite seu interesse abaixo:

Quer Aprender sobre Power Query?

Conheça nossa formação e tudo que você pode aprender com ela.

Mais conteúdos gratuitos para você!

OPA, vejo que você é novo por aqui!

Temos um presente de boas vindas para os amantes de Blog!

E ai FERA?!

Não vou atrapalhar tua leitura deste super artigo.

Só quero te dizer que por ser um visitante novo aqui no site, nosso sistema está programado para te enviar um cupom de desconto para a FORMAÇÃO POWER QUERY 2.0, que é um pacotão de cursos do JOVI, com mais de 300 horas de conteúdo.

Informe seus dados a seguir, que te enviaremos as instruções para resgate desse cupom exclusivo.

Exemplo 👉 +5511988776655 👈 [não informar pontos, traços e parênteses]

explicação telefone

Números do Brasil devem iniciar com +55
Preencha conforme o exemplo, pois o presente será enviado por WhatsApp para esse número. 

Após enviar, pode fechar essa janela, que seu presente já está em processamento.

A ementa possui centenas de aulas, e resumimos em um painel de PowerBI o qual enviaremos a você.

Preencha seu nome e email que em instantes receberá a ementa completa deste pacote de cursos.

Formato Aceito: [+ código do pais] [código de área] [número]